Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
02 Chevy S10 Oxygen Sensor Question
Author Message
InADream Offline
Member
***

Posts: 4
Joined: Jun 2008
Reputation: 0
Post: #1
02 Chevy S10 Oxygen Sensor Question
I have an 02 S10 that I just got finished installing my HHO Generator... I want to adjust the sensors before turning on the unit.. Just recently, my computers engine light came on.. When they read the code it says O2 sensor Malfunction on the 2 pre-cat... Autozone cleared the code and they have not come back on it has been a week... Now here are my questions... Do I replace my O2 sensors then get a voltage manipulator to lean the truck out? Do I Leave the old ones in and add the manipulator? Also, does anyone know if they are narrow band or wide band...

Sorry for all the questions so soon, but love the board and I know somewhere here can help..

Thanks

Dan
06-20-2008 01:45 PM
Find all posts by this user Quote this message in a reply
jrmalin Offline
Member
***

Posts: 7
Joined: Jun 2008
Reputation: 0
Post: #2
RE: 02 Chevy S10 Oxygen Sensor Question
personally I would leave them in for now, if you have a bad o2 sensor it will show up, but the efie docs to build you own efie says it will help a "slow" o2 sensor.
06-29-2008 10:52 AM
Find all posts by this user Quote this message in a reply
porkchop Offline
Member
***

Posts: 5
Joined: Jul 2008
Reputation: 0
Post: #3
RE: 02 Chevy S10 Oxygen Sensor Question
02 Chevy S10 Oxygen Sensor Question

Did you try rapping tin foil around the o2 sensor yet? I have a 92 s-10 Blazer and I'm in the middle of this stage also , I just installed the map senor enhancer yesterday and I'm still testing for results . May I ask , where is your HHO feed connected ? Mine is tee'ed between the PVC valve and the throddle body .
07-21-2008 07:58 PM
Find all posts by this user Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)