Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Saturn Setup
Author Message
hydrodine Offline
Member
***

Posts: 206
Joined: Mar 2008
Reputation: 0
Post: #1
Saturn Setup
Here is my saturn setup, cell works great but no increase in mileage.

http://www.nature-powered.com/saturn

series cell, 9 amp hot, 1.2 lpm and 105 degree temp.
07-08-2008 04:59 PM
Find all posts by this user Quote this message in a reply
colchiro Offline
Moderator
*****

Posts: 3,265
Joined: Feb 2008
Reputation: 11
Post: #2
RE: Saturn Setup
hydrodine Wrote:Here is my saturn setup, cell works great but no increase in mileage.

http://www.nature-powered.com/saturn

series cell, 9 amp hot, 1.2 lpm and 105 degree temp.
Wow, beautiful looking cell.

What have you tried besides koh?

Rick

Links: Documents / Tuning for Mileage | Toyota Sensors | Autoshop Sensor Tutorials
07-08-2008 05:07 PM
Find all posts by this user Quote this message in a reply
hydrodine Offline
Member
***

Posts: 206
Joined: Mar 2008
Reputation: 0
Post: #3
RE: Saturn Setup
Just about everything you can think of in different electrolytes and koh is by far the best choice. I have learned that lower amp draw and less heat i dont get red mud with the 304 ss. I had this cell up to 25 amps and it produced almost 5 lpm but it started getting hot.
(This post was last modified: 07-09-2008 04:54 AM by hydrodine.)
07-08-2008 05:12 PM
Find all posts by this user Quote this message in a reply
jksav7 Offline
Senior Member
****

Posts: 444
Joined: Apr 2008
Reputation: 0
Post: #4
RE: Saturn Setup
The link isn't working for me.


hydrodine Wrote:Here is my saturn setup, cell works great but no increase in mileage.

http://www.nature-powered.com/saturn

series cell, 9 amp hot, 1.2 lpm and 105 degree temp.
07-08-2008 05:14 PM
Find all posts by this user Quote this message in a reply
hydrodine Offline
Member
***

Posts: 206
Joined: Mar 2008
Reputation: 0
Post: #5
RE: Saturn Setup
I just checked it and it is working, its my own server.
07-08-2008 05:16 PM
Find all posts by this user Quote this message in a reply
colchiro Offline
Moderator
*****

Posts: 3,265
Joined: Feb 2008
Reputation: 11
Post: #6
RE: Saturn Setup
hydro, I missed most of your posts.

This cell with/without the EFIE... what did you get for mileage?

Did you throw any CEL's with the EFIE? Were they lean or rich?

Rick

Links: Documents / Tuning for Mileage | Toyota Sensors | Autoshop Sensor Tutorials
(This post was last modified: 07-08-2008 05:47 PM by colchiro.)
07-08-2008 05:45 PM
Find all posts by this user Quote this message in a reply
mattsauto Offline
Member
***

Posts: 112
Joined: Jul 2008
Reputation: 0
Post: #7
RE: Saturn Setup
hydrodine Wrote:Here is my saturn setup, cell works great but no increase in mileage.

http://www.nature-powered.com/saturn

series cell, 9 amp hot, 1.2 lpm and 105 degree temp.

Is this a 5 series cell ???

2.8v at each cell at 14v???

are you using 2 (two) plates only (in each cell)???

Is your KOH concentration Below 24%???

Let me know...
(This post was last modified: 07-08-2008 06:02 PM by mattsauto.)
07-08-2008 05:58 PM
Visit this user's website Find all posts by this user Quote this message in a reply
hydrodine Offline
Member
***

Posts: 206
Joined: Mar 2008
Reputation: 0
Post: #8
RE: Saturn Setup
colchiro Wrote:hydro, I missed most of your posts.

This cell with/without the EFIE... what did you get for mileage?

Did you throw any CEL's with the EFIE? Were they lean or rich?

All of my cel's were due to the o2 sensor, including the down stream also. Right now i have the efi set at 175 mv and so far no cel but again no mileage gains.
07-08-2008 06:08 PM
Find all posts by this user Quote this message in a reply
hydrodine Offline
Member
***

Posts: 206
Joined: Mar 2008
Reputation: 0
Post: #9
RE: Saturn Setup
mattsauto Wrote:
hydrodine Wrote:Here is my saturn setup, cell works great but no increase in mileage.

http://www.nature-powered.com/saturn

series cell, 9 amp hot, 1.2 lpm and 105 degree temp.

Is this a 5 series cell ???

2.8v at each cell at 14v???

are you using 2 (two) plates only (in each cell)???

Is your KOH concentration Below 24%???

Let me know...

Yes to all except koh, i used 4 tablespoons to a gallon of water, that gives me the 9 amps hot.
07-08-2008 06:09 PM
Find all posts by this user Quote this message in a reply
hydrodine Offline
Member
***

Posts: 206
Joined: Mar 2008
Reputation: 0
Post: #10
RE: Saturn Setup
I am getting so feed up with no gains, map, efi etc... I know it is not my cell design, it works to good to be a problem. I am open to any suggestions to get some mileage gain.
07-08-2008 06:12 PM
Find all posts by this user Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)