Fuel-Saver Forums
Saturn Setup - Printable Version

+- Fuel-Saver Forums (http://www.fuel-saver.org)
+-- Forum: FuelSaver-MPG Products (/Forum-FuelSaver-MPG-Products)
+--- Forum: EFIE Support (/Forum-EFIE-Support)
+--- Thread: Saturn Setup (/Thread-Saturn-Setup)

Pages: 1 2 3 4


Saturn Setup - hydrodine - 07-08-2008 04:59 PM

Here is my saturn setup, cell works great but no increase in mileage.

http://www.nature-powered.com/saturn

series cell, 9 amp hot, 1.2 lpm and 105 degree temp.


RE: Saturn Setup - colchiro - 07-08-2008 05:07 PM

hydrodine Wrote:Here is my saturn setup, cell works great but no increase in mileage.

http://www.nature-powered.com/saturn

series cell, 9 amp hot, 1.2 lpm and 105 degree temp.
Wow, beautiful looking cell.

What have you tried besides koh?


RE: Saturn Setup - hydrodine - 07-08-2008 05:12 PM

Just about everything you can think of in different electrolytes and koh is by far the best choice. I have learned that lower amp draw and less heat i dont get red mud with the 304 ss. I had this cell up to 25 amps and it produced almost 5 lpm but it started getting hot.


RE: Saturn Setup - jksav7 - 07-08-2008 05:14 PM

The link isn't working for me.


hydrodine Wrote:Here is my saturn setup, cell works great but no increase in mileage.

http://www.nature-powered.com/saturn

series cell, 9 amp hot, 1.2 lpm and 105 degree temp.



RE: Saturn Setup - hydrodine - 07-08-2008 05:16 PM

I just checked it and it is working, its my own server.


RE: Saturn Setup - colchiro - 07-08-2008 05:45 PM

hydro, I missed most of your posts.

This cell with/without the EFIE... what did you get for mileage?

Did you throw any CEL's with the EFIE? Were they lean or rich?


RE: Saturn Setup - mattsauto - 07-08-2008 05:58 PM

hydrodine Wrote:Here is my saturn setup, cell works great but no increase in mileage.

http://www.nature-powered.com/saturn

series cell, 9 amp hot, 1.2 lpm and 105 degree temp.

Is this a 5 series cell ???

2.8v at each cell at 14v???

are you using 2 (two) plates only (in each cell)???

Is your KOH concentration Below 24%???

Let me know...


RE: Saturn Setup - hydrodine - 07-08-2008 06:08 PM

colchiro Wrote:hydro, I missed most of your posts.

This cell with/without the EFIE... what did you get for mileage?

Did you throw any CEL's with the EFIE? Were they lean or rich?

All of my cel's were due to the o2 sensor, including the down stream also. Right now i have the efi set at 175 mv and so far no cel but again no mileage gains.


RE: Saturn Setup - hydrodine - 07-08-2008 06:09 PM

mattsauto Wrote:
hydrodine Wrote:Here is my saturn setup, cell works great but no increase in mileage.

http://www.nature-powered.com/saturn

series cell, 9 amp hot, 1.2 lpm and 105 degree temp.

Is this a 5 series cell ???

2.8v at each cell at 14v???

are you using 2 (two) plates only (in each cell)???

Is your KOH concentration Below 24%???

Let me know...

Yes to all except koh, i used 4 tablespoons to a gallon of water, that gives me the 9 amps hot.


RE: Saturn Setup - hydrodine - 07-08-2008 06:12 PM

I am getting so feed up with no gains, map, efi etc... I know it is not my cell design, it works to good to be a problem. I am open to any suggestions to get some mileage gain.